Essbase Service not starting

After I figured out the issue with OpenLDAP, I recently saw a similar problem with my Essbase service. However many times I tried to start it, it would just shutdown immediately. This could have been a result of the improper shutdown I mentioned as a reason for the OpenLDAP database to get corrupted.

Fixing essbase is not without losses. I discovered that the security file had been corrupted and hence essbase shutdown soon after I started it.

I went to my application backup folder and copied the essbase.sec file back to the current deployment. The essbase.sec needs to be replaced with a working version. When I started the service again, it was back up and running.

Please note that if you don’t have a current backup, then a lot of the security information that has changed since you’re last backup will need to be done again. I had a very recent backup so I was saved from this hassle.

Advertisements

2 thoughts on “Essbase Service not starting

  1. It should be noted that historically Essbase would backup the security file automatically every time the Essbase server successfully starts up. (e.g. after an OS reboot) and this file would be stored in the same directory where the Essbase.sec file is stored and would be called “essbase.bak”. I say historically because the last time i actually verified this was happening was in 9.3.1. if the back up file is not also corrupted then a restore is as simple as renaming the file essbase.sec to essbase.bad and essbase.bak to essbase.sec and restarting the service.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s